Problemas con tarjetas ATI en Jaunty


Hola amigos, para los que se le ha presentado el problema de instalar los drivers restrictivos de Ubuntu Jaunty, que dan por defectos, he encontrado la solucion:

Corregido: Lamentablemente no se puede hacer mas que instalar los drivers abiertos de ati, que no entregan muchos efectos en la x o bien volver a la 8.10 e instalar Catalyst 9.3, ya que oficialmente no hay soporte para X.org 1.6 que es la que viene con Jaunty.

Lamento darles esta noticia, pero a penas salga una actualizacion o bien que se mejoren los drivers abiertos, no tendremos mas que conformarnos con metacity o Intrepid (8.10)

Mis sinceras disculpas

Primero debemos descargar los Catalyst desde la pagina de AMD en el siguiente enlace

http://support.amd.com/la/gpudownload/Pages/index.aspx

Luego debemos acceder a la carpeta donde descargamos los catalyst correspondientes a nuestra placa e ingresar por terminal lo siguiente

sh ./ati-driver-installer-9.2-x86.x86_64.run –buildpkg Ubuntu/jaunty

Ahi se crearan los paquetes para intalar en nuestra nueva distro, se crearan varios paquetes de los cuales serviran solo 3

si vas a instalar en 32 bits son los siguientes :
sudo dpkg -i xorg-driver-fglrx_*.deb fglrx-kernel-source_*.deb fglrx-amdcccle_*.deb

archivos

Al terminar de instalar estos tres archivos, reiniciamos nuestra maquina y tendremos nuestra tarjeta de video con graficos 3D y sin problemas

Nota: Esta instalacion se configuro una tarjeta de video HD3850 de Sapphire.


18 pensamientos en “Problemas con tarjetas ATI en Jaunty

  1. si vas a instalar en 32 bits son los siguientes :
    sudo dpkg -i xorg-driver-fglrx_*.deb fglrx-kernel-source_*.deb fglrx-amdcccle_*.deb

  2. Tengo una duda:
    Entiendo que Jaunty viene con X.org 1.6 y que los drivers de ATI previos a la versión 9.4 (actual) no soportan dicha versión de X.org.

    El problema es que desde la versión 9.4 de Catalyst, ATI dejó de dar soporte a las tarjetas “antiguas”. Así que, en teoría, si uno no tiene una tarjeta de vídeo de última generación, no puede instalarse los drivers privativos 9.4, los cuales serían los únicos compatibles con Jaunty.

    Ahora bien, veo que en esta entrada señalas que estás instalando la versión 9.2 de Catalyst… la que teóricamente no debería ser compatible con la versión de X.org que viene en Jaunty. Si fuera posible, me gustaría que detallaras qué modelo de ATI tienes, y qué versiones de los drivers y X.org estás ocupando…

    Gracias :9

  3. A mi también me interesaria saberlo. He intentado lo mismo con los 9.3 y no funciona con la radeon x1300 que tengo. Alguien puede confirmar que funciona con el 9.2 en las radeon viejas, con jaunty i el nuevo x.org?
    Gracias…

  4. Buenas a todos y gracias de antemano. Tengo una gráfica ATI Radeon 9600XT y he actualizado Ubuntu desde la versión 8.10 a la versión 9.04. Tengo instalado Ubuntu y Windows de manera compartida.
    Tengo 2 aparentes problemas:
    1) En la pantalla de selección de arranque del sistema operativo no me aparece el nombre de la versión nueva de Ubuntu.
    Es decir, antes me aparecía el nombre de la versión a arrancar con las opciones de las actualizaciones, etc. Y ahora sale el mismo nombre y arrancá con el sistema de la versión nueva 9.05
    2) Esta claro que esto me daría igual si me funcionase bien (lo incluyo como problema por si acaso) pero el segundo problema es sobre los drivers.
    Ubuntu me avisa que no encuentra los drivers y que tendré que trabajar en modo “low graphics” pero, dandome igual cualquiera de las opciones que me da a elegir (configurar graficos, etc) siempre acabo llegando a la consola y no se como salir de ahi, o restaurar el sistema o algo…

    ¿Alguien podría indicarme?
    Saludos y de nuevo gracias.

  5. @ Asustado:
    Supongo que te ha pasado lo que a mi, al actualizar se instalan los fglrx para radeon però estos ya no son compatibles. Prueba en el menu de arranque a entrar en safe mode (la segunda opcion) y seleccionar prompt con root i funciones de red. O si no desde la misma consola a la que dices llegar.

    Una vez ahi:

    sudo apt-get remove xorg-driver-fglrx

    para desinstalar los drivers privativos y luego:

    sudo apt-get installl xserver-xorg-video-ati xserver-xorg-video-radeon

    para instalar los libres.

    Tal vez no te vaya igual de bien, però al menos deberia arrancarte el entorno grafico. Si no, prueba la opcion de reconfigurar el xserver…

    Yo aun sigo esperando que alguien me diga algo de mi radeon x1300…

    Salut i sort!

  6. Lamentablemente amigos, solo queda configurar por los drivers libres, ya que por el momento los catalyst de ATI, no estan trabajando para tarjetas ni nuevas ni antiguas, hay algunas que por defecto las toma, y el 90% de los casos son las integradas de la serie xpress 200 – 300.-

    Tendremos que esperar que se libere una actualizacion de drivers o bien mantenernos en intrepid.

    Cabe recordar que ami me trabajo compiz y murio al dia.-

    atte.

  7. Una cosa @ asustado, cuando reinicies tal vez te siga diciendo que no detecta el servidor grafico porque tendras un lio de drivers. Dale a reconfigurar x server para que te pille los nuevos y ve eligiendo las opciones. Asi deberia funcionar.

    Por cierto, lo de que te salga el nombre antiguo en el grub creo que no tendra nada que ver. Si lo instalaste por wubi la primera vez es normal ya que ese nombre lo pone en el arranque comun de windows i ubuntu y luego al actualizar no lo cambia. A mi me pasa lo mismo, de hecho yo uso ubuntu 9.04 y en el arranque aun me aparece el Kubuntu 8.04 del que ya no queda ni rastro (ya no tengo ni kde, i he pasado por hardy, intrepid i ahora jaunty). Pero ponga el nombre que ponga eso te redirige al arranque del ubuntu que tengas instalado.

    Suerte!

  8. Pues si, tuve que darle una orden que me indicaba en la propia consola y después de un ratito haciendo “cosas” el solo le di la segunda orden que me dijiste y contestó que ya estaba instalada creo. Ahora ya puedo ver el entorno gráfico y todo. Muchas gracias de nuevo Dárent, ya creía que tendría que reinstalar (es que no tengo mucha idea y siempre tiro de esa opción:))
    Saludos y suerte tu también!!

  9. De nada, a ver si se aclara esto porque estan los foros petados. Al menos, por el momento, tenemos escritorio para seguir buscando xD

    Salut!

  10. despues de instalar la actualizacion parcial de ubuntu 9.04 y al intentar reiniciar mi laptop (inspiron 1501) la pantalla ha estado siempre en negro y el puntero del mouse no responde puedo acceder con alt+F4 a la terminal y aun que he intentado desinstalar xserver por que segun entiendo eso me ayudaria siguo sin poder ver nada en mi lap soy muy inexperto que me aconsejarian.
    saludos desde Mexico.

  11. la solución está en el kernel que incorpora los drivers libres. Es necesario una versión del kernel 2.6.29 o superior para que los drivers de ati funcionen bien.

    podeis descargarlos de
    http://kernel.ubuntu.com/~kernel-ppa/mainline/

    en concreto probé instalando el kernel 2.6.29 en Jaunty para una ati x1700 y me fue bien, se arreglaron los problemas. Esto es lo que hay que instalar
    http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.29.3/linux-headers-2.6.29-02062903_2.6.29-02062903_all.deb
    http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.29.3/linux-headers-2.6.29-02062903-generic_2.6.29-02062903_i386.deb
    http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.29.3/linux-image-2.6.29-02062903-generic_2.6.29-02062903_i386.deb
    en caso de usar 64 bits elegir las versiones correspondientes

    O bien probar otro kernel, el 2.6.30 también funciona en Jaunty aunque está pensado para funcionar en Karmik koala.

  12. alguien podría explicarme de forma sencilla,como actualizar mi ubuntu del 8.10 al 9.04. tengo una tarjeta ati radeon 1200 integrada.cuando intento actualizar me dice lo siguiente:
    ESTE EQUIPO ESTA USANDO ACTUALMENTE EL CONTROLADOR FGLRX DE AMAD.no existe ninguna versión de este controlador que funcione con su hardware.podría alguien responderme. estaría agradecido.

  13. Ya decia yo que habia algo raro con los driversO_o.
    Tengo una HD4850 con ubuntu 9.04 y va de maravilla pero tengo una 9600xt y la probe con ubuntu 9.04 y el 9.10 pero no funcionaron los drivers. Funcionaba perfecta con suse 10.1 pero ahora ninguna distro de linux nueva me sirve. Voy a tener que usar una mas viejita. ^_^

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s